AnsweredAssumed Answered

Survey123 - Receiving a lot of 401 Unauthorized errors

Question asked by blaws@Newark.de.us_CityOfNewarkDE on Feb 28, 2019
Latest reply on Mar 4, 2019 by blaws@Newark.de.us_CityOfNewarkDE

We have a survey (developed in Survey123 Connect) that writes data directly to a related table in our SDE enterprise database.  The application has  been working  for approximately a year.  Today,  one of our field crew stopped by our office as he was receiving this error when trying to submit a survey on his tablet:

 

Survey123 error 401 unauthorized from submitting a survey

Several of us tested the survey with our different accounts and devices, and received the same error.  A couple of weeks ago I made a change to this survey (added an additional choice to a question) and republished this survey.  Today was the first time our field worker had tried to use it.  Assuming this might be the cause of the issue I changed the survey back to the way it was (removed the new choice) and attempted to republish and then received this error:

 

Survey123 error 401 unauthorized from publishing a survey

I became curious and was wondering if I could replicate the creation of this survey from an existing feature service.  The attempt immediately returned  this error:

 

Survey123 error 401 unauthorized from creating a survey

 

My co-workers and I tried some other troubleshooting ideas and found  we can submit surveys that write to a service if it's hosted on ArcGIS Online, and we can create surveys from feature services that are hosted on ArcGIS Online.  I downloaded the Survey123ConnectClassic and Survey123Classic apps to see if the newer versions might be our issue. Using the same workflow,  I received  the same errors every step of the way.  We also looked at editing feature attributes directly in a web map on ArcGIS Online as well as in Collector and had no errors there.  We also were able to publish new services to our server from ArcMap with no errors as well.  It appears if we try to do anything with Survey123 where the application is accessing our SDE enterprise database on our Server site, we receive this 401 Unauthorized error.  We checked  the existing permissions on the table and related feature dataset and classes and all were set up as before when the application was working. 

 

My colleagues and I spent most of our day searching for causes and troubleshooting the issue. We had no success in finding a remedy for this error.  We are hoping the GeoNet community can provide help. Our enterprise SDE database, ArcGIS for Server and our webadaptor are all at version 10.4  We are using ArcMap 10.6 and Pro 2.3.1.  All our office personnel run Windows 10 and our field crews are using Windows 10 ruggedized tablets and our server setup uses ADFS.

Outcomes