AnsweredAssumed Answered

Web apps causing ArcGIS Enterprise to crash

Question asked by hamishmills on Feb 21, 2019
Latest reply on Mar 4, 2019 by hamishmills

Hello all! 

 

Early last year we had an issue where whenever web apps were operating on our portal, the entire ArcGIS enterprise stack would intermittently go unresponsive for up to 15 minutes or more and sometimes go down completely. As soon as web app/s were removed the crashes/hanging sessions stopped. This issue was never resolved and now roughly a year on, and having just upgraded to the 10.6.1 update, this issue is still occurring. Naturally we cannot continue like this, we need to be able to use web apps on our ArcGIS Portal!

 

More detail on issue:

- It seems that ArcGIS Server is hanging first then everything else will lock up eventually, site hangs up for 5-15 mins then sometimes comes back or otherwise crashes completely.

- Often it has been noticed that if you catch it early and restart the ArcGIS Server component, Portal will become responsive again almost immediately (left too long both can become entirely unresponsive).

- We were unable to find anything conclusive in logging and extensive testing only pointed to the apps as the trigger for whatever was happening.

- Some evidence may point to editable feature services in the web apps, but this is yet to be fully proven. (i.e. may be related to arc objects accessing enterprise gdb?)

 

Environment details:

ArcGIS Enterprise 10.6.1;             PostgreSQL 9.5.7;          Microsoft server 2016;

 

AGS server machine specs:                          Portal machine specs:                             SQL machine specs:                              

 

 

                      

Any ideas or similar experiences anyone has had are most welcome! Desperate to get this one resolved! 

Outcomes