AnsweredAssumed Answered

LocalServer won't start geoprocessing services

Question asked by AltErica on Feb 20, 2019
Latest reply on Oct 28, 2019 by gnsharansai

I have a .NET application with Local Server, and it starts and displays a map service from a map package. However, it cannot start the geoprocessing service I'm also trying to include. I've tried with the gpk that I actually need, a gpk with a simple Buffer operation (just for testing purposes), and a gpkx with a simple Buffer operation. All are giving the same error:

 

Failed to create service examplemodel GPServer. Worker process 'examplemodel_host' exited while attempting to service request (attempt 1 of 1): endpoint='admin' headers={} params={asynchronous=, filePath=c:\temp\examplemodel.gpk, jobDir=C:\Users\[.....]\AppData\Local\Temp\1\arcgisruntime_19956\examplemodel\jobs, maxRecords=1000, name=examplemodel, outputDir=C:\Users\[.....]\AppData\Local\Temp\1\arcgisruntime_19956\examplemodel, type=GPServer, virtualDir=http://127.0.0.1:50000/5rc2jC/outputdir/examplemodel} res='create' post=0 Crash dump path=C:\Users\[.....]\AppData\Local\Temp\1\ArcGISRuntimeErrorReports\arcgisruntime_100.3.0.2102_service_20190219_194809.dmp

I did check the ArcGISLocalServer_100.3.AGSDeployment file, and changed the Geoprocessing lines:

 

      <Package id="ProGeoProcessing" name="Geoprocessing" enabled="true">

      <Package id="ArcMapGeoprocessing" name="Geoprocessing" enabled="true">

 

Unfortunately, I'm still getting the same error. What else do I need to fix?

Outcomes