AnsweredAssumed Answered

How do I enable an Enterprise Geodatabase in a PostgreSQL with PostGIS installed?

Question asked by andrewfclark on Feb 12, 2019
Latest reply on Mar 1, 2019 by George_Thompson-esristaff

Hi All,

 

I have ArcGIS Desktop 10.6.1 installed on one server where I also have ArcGIS Enterprise 10.6 installed. On a separate server, I also have PostgreSQL 10.3 installed with PostGIS 2.4 Installed. I would like to enable the Enterprise Geodatabase in the PostgreSQL database (which has an SDE username installed with full admin/ownership privileges) so I can integrate the database with Portal and Insights. I have been told by ESRI Technical Support that I do not need ST_geometry installed because I already have the PostGIS extension installed in the database, but every time I try to enable the Geodatabase through ArcCatalog i crashes with the error message: "You must copy the latest ST_GEOMETRY library to the PostgreSQL software location."

 

Please help!

 

Andrew

Outcomes