AnsweredAssumed Answered

Can't update the arcgispro package

Question asked by simo Champion on Feb 7, 2019
Latest reply on Feb 13, 2019 by Dan_Patterson

After upgrading my ArcGIS Pro to 2.3, the python environment I previously cloned and then modified stopped working because of the "version mismatch":

 

 

 

When I list the arcgis related packages I find the arcgispro package version is still 2.2, but the latest version should the be 2.3, and I believe that's why ArcGIS Pro reported "verion mismatch".

 

So I tried to install arcgispro 2.3 in my environment, but this seems not allowed, because there were conflicts.Please see below:

 

 

Since I have installed many other third-party packages, I don't want to give up my current environment until I run out of options. 

 

I have cloned the default env of the new ArcGIS Pro 2.3, and successfully upgraded the ArcGIS Python API to 1.5.3, this re-assures that ArcGIS Python API 1.5.3 is compatible, it's the arcgispro 2.2 python package which is causing the problem.

 

Anyone has the same issue?

Outcomes