AnsweredAssumed Answered

ArcCatalog does not show all non-spatial Oracle tables not registered with SDE

Question asked by yguan16 on Feb 1, 2019
Latest reply on Feb 1, 2019 by yguan16

Really puzzled on this one. I ran into this strange issue with both ArcSDE 10.3.1/Oracle 12.1.0.1 and  ArcSDE 10.5.1/Oracle 12.1.0.2 recently. We have been in 10.3.1 for 2 years now. I have created a lot of non-spatial in SQL Developer and never register them with SDE. This week, I found ArcCatalog (10.3.1 and 10.5.1) shows only some of them, but not most of them.  I create a new one in different schemas using SQL Developer, it does not show up in any of them in Catalog. I added the objectid column in SQL Developer, the table still not show in Catalog. But when I add shape "SHAPE SDE.ST_GEOMETRY"  column, it will show up in Catalog. I tried using the Catalog tool "Create unregistered table" to create an empty table. The table is shown with "OBJECTID" in SQL Developer, but not show up in the Catalog. If I use the "Create table" tool, the table shows up in Catalog. Look like using "Create table" tool to create the table and using "Add Field" is the only way to make the table appear in Catalog. But why it does show some of the tables created in the same way in the past, but not all of them? I don't want the table to have objectid column. 

Outcomes