AnsweredAssumed Answered

Issue when change default icon of a widget

Question asked by smauri.at on Dec 19, 2018

Hi all, here is my scenario:

my organization create a web app, sharing it in a group, where other users from external organization are invited to collaborate.

Link of WebApp when I log in with internal user: http://ersaf.maps.arcgis.com/apps/webappviewer/index.html?id=4695782fb6e34c51b30bca0c5d1c2571

User from external subscription must log in with another URL: http://lispa.maps.arcgis.com/apps/webappviewer/index.html?id=4695782fb6e34c51b30bca0c5d1c2571

Same ID, but it appears like the original webapp is virtually “hosted” on his organization.

 

The problem comes in when I change default icon of a widget with custom image.

Here is webapp viewed from internal user.

 

And here is webapp viewed from external user.

 

 

Link of image from webapp with “correct” URL

http://ersaf.maps.arcgis.com/sharing/rest/content/items/4695782fb6e34c51b30bca0c5d1c2571/resources/inConfig/19834296465498769.png?token=....

(token removed)

Link of image from webapp with “modified” URL

http://ersaf.maps.arcgis.com/sharing/rest/content/items/4695782fb6e34c51b30bca0c5d1c2571/resources/inConfig/19834296465498769.png?token=.....

(token removed)

It's rather obvious that URL of second image should start with domain of external organization (lispa).

Here is what happen if I paste image URL logged as external user

 

And now if I correct prefix, always logged as external user.

Please fix it as soon as possible! Thank you

Cheers

 

Stefano

Outcomes