AnsweredAssumed Answered

Publishing a Service Error - ServerHealthCheckTask

Question asked by dpopovic on Dec 17, 2018
Latest reply on Feb 25, 2019 by dpopovic

I'm having a problem sharing a service via ArcMap and generally accessing REST services.

 

Configuration:

  • ArcGIS for Server Version 10.5.1 runs as Windows Service (port: 6080)
  • WebAdaptor Version 10.5.1 runs on Tomcat as war File (forwards from port 6080 to port 6443).
  • Windows 10 Pro

I receive following error in Tomcat when Web Adaptor is running:

NOTE: (Fehler in Admin-Anforderung für Abruf von Computern Connection refused - from German: Error in Admin Request at call from Computer Connection refused)

 

17-Dec-2018 09:35:01.044 WARNUNG [Timer-0] com.esri.arcgis.server.wa.cluster.UpdateServerCacheTask.updateServerList Exception in connecting to http://localhost:6080/arcgis/admin Fehler in Admin-Anforderung für Abruf von Computern Connection refused: connect
17-Dec-2018 09:35:02.060 WARNUNG [Timer-0] com.esri.arcgis.server.wa.cluster.UpdateServerCacheTask.updateServerConfig Exception in connecting to http://computername.domain.LOCAL:6080/arcgis/admin Fehler in Admin-Anforderung für Abruf von Computern Connection refused: connect
17-Dec-2018 09:35:03.075 WARNUNG [Timer-0] com.esri.arcgis.server.wa.cluster.UpdateServerCacheTask.updateServerConfig Exception in connecting to https://computername.domain.LOCAL:6443/arcgis/admin Fehler in Admin-Anforderung für Abruf von Computern Connection refused: connect
17-Dec-2018 09:35:09.545 INFORMATION [Timer-4] com.esri.arcgis.server.wa.cluster.ServerHealthCheckTask.updateServerStatus Checking Healthcheck status for hostname : computername.domain.LOCAL
17-Dec-2018 09:35:10.564 INFORMATION [Timer-4] com.esri.arcgis.server.wa.cluster.ServerHealthCheckTask.updateServerStatus Healthcheck status for hostname : computername.domain.LOCAL false
17-Dec-2018 09:35:19.549 INFORMATION [Timer-4] com.esri.arcgis.server.wa.cluster.ServerHealthCheckTask.updateServerStatus Checking Healthcheck status for hostname : computername.domain.LOCAL
17-Dec-2018 09:35:20.565 INFORMATION [Timer-4] com.esri.arcgis.server.wa.cluster.ServerHealthCheckTask.updateServerStatus Healthcheck status for hostname : computername.domain.LOCAL false

 

I followed the steps to install AGS (ArcGIS for Server) and webadaptor again (Install ArcGIS Server on one machine—Installation Guides (10.5) | ArcGIS Enterprise ).

As a results, webadaptor is running, but shows the following error when trying to register

Error: Could not access any GIS Server machines. Please contact your system administrator 

I followed the steps in the answer and it doesn't help.

Although I don't have agsusers and agsadmin group but I have enabled settings for local users and admin (account from which AGS and webadaptor were installed)from following thread.

Error: Access Denied or The connection could not be made 

 

The services in AGS are not responding when webadaptor is running. When I restart PC, AGS is running, and all Publishing Service, however when I try to share service using AcMap, it says that is not being started.

I followed following thread to find try to solve:

User does not have permissions to access 'system/publishingtools.gpserver 

I tried both connecting to AGS via:

http://localhost:6080/arcgis

and

https://computername.domain.LOCAL:6443/arcgis or https://localhost:6443/arcgis/
to publish service and it always responds that Publishing Service is not running.

 

Ports: 6080,6443 are opened for AGS at Windows Firewall and I use only admin account for log in at AGS.

 

Summary:

AGS and webadaptor, once the PC is restarted work fine, however once I try to publish service everything crashes.

 

Any help is highly welcome!

 

Dejan

Outcomes