AnsweredAssumed Answered

Cascade Storymap Jumps to Web Map App

Question asked by rlmulvey_usfs on Dec 6, 2018
Latest reply on Dec 7, 2018 by OEvans-esristaff

I have spent a long day troubleshooting this issue with Cascade Builder. The issue arose when two new web map apps were added to the project. A third web map app was already in the project and not causing issues. When the story map is opened and you beginning scrolling through the content, it suddenly jumps to the first of the two maps.

 

Troubleshooting so far:

In Story Map:

-changed from narrative to immersive style for those two maps, though that was not preferred (didn't fix)

-changed appearance to button enabled from auto enabled (didn't fix)

-when the first map was removed, the story map jumped instead to the second map

 

In Web App Builder:

-hid/removed splash screen (didn't fix)

-changed from splash to About widget (didn't fix)

-totally rebuilt the web map app by replicating the one working web map app and replaced with the desired web map

-once the rebuild was complete but three of the previous widgets retained, the problem persisted

-next, I removed all widgets (IT WORKED! NO JUMPING!) and next began to add the widgets back one by one

-the first one I added was the legend- IT WORKED! Or, should I say, it worked until I selected for it to be visible upon opening.

 

Can anyone help? Has anyone had similar problems? Why would the legend set to open with the map create this issue? The other (functioning) web map app in this project also has a widget set to be visible on opening, the summary widget, and this does not cause a problem.

 

Your help is much appreciated. We are on a tight timeline for this project.

 

Robin Mulvey

robin.mulvey@usda.gov

Outcomes