AnsweredAssumed Answered

Run ArcGIS Desktop (Python 2x), Pro (Python 3x), and Anaconda Python 2.7 all on the same machine?

Question asked by sguilford_ngexplore on Nov 28, 2018
Latest reply on Dec 14, 2018 by SWalbridge-esristaff

I posted this as a comment on this thread, but as the OP's answer involved messing around copying and pasting files, I think it warrants a new question:

 

I'm currently running ArcGIS Desktop 10.6 (python 2.7) and ArcGIS Pro 2.2.4 (python 3x) on the same machine. I have also installed the Anaconda Python 2.7 32-bit distribution so I can use arcpy in the Spyder IDE. However, this means that some basic tools in Pro now throw errors when I try to run them - I assume because it's trying to access the older version of Python. Does Esri have any official suggestions?

 

 

Thank you.

Outcomes