AnsweredAssumed Answered

Cannot publish a tool to ArcGIS Server - Error 001270

Question asked by ctownsend16 on Nov 15, 2018

Hi, I'm trying to publish a tool I built in model builder under ArcMap 10.6.1, to ArcGIS Server 10.6.

 

I'm having two problems with this.

1) It won't publish as a geoprocessing service, I keep getting the error 001270: Consolidating the data failed. I've tried rerunning the tool, saving the outputs to different (shorter filepath) locations, I've tried UNC paths, nothing works.

 

2) The second problem is that two of the four user input parameters are being forced on me by the publishing tool as constants, when they should be variables....why? I've checked the model in model builder and can't see any differences (The model runs fine and does what it's supposed to)

 

In the attached screenshots below, pole_screening_normal.png is what it's supposed to look like....the user selects a spreadsheet, creates or selects a workspace folder, creates a geodatabase inside that folder and gives a name to the poles feature class.

pole_screening_broken.png is what it looks like in the preview option in the service editor. I have no idea why it's doing this...?

 

Help please!

Outcomes