AnsweredAssumed Answered

ArcGIS Pro stuck at configure licensing window

Question asked by hamishmills on Nov 11, 2018
Latest reply on Nov 14, 2018 by aam-esristaff

Hello,

 

Attempting to deploy enterprise based ArcGIS Pro licensing from our own portal installation. Everything seems to have worked smoothly (received and activated .llc file with License manager and successfully generated and applied json license file to our portal) until the very last step of logging into ArcGIS Pro. Installs of ArcGIS Pro directly on the licensing/portal VM seem to launch with licensing working correctly, launching on any other machine either on the same sub network and/or outside of the sub network do not work. Hence seems very likely that it is networking related but is beyond my skills to prove this beyond a doubt.

 

Using 10.6 Server/portal infrastructure and License Server Manager 2018.0. On Cloud VM windows 2016 servers. Tried both ArcGIS Pro 2.1 and 2.2 to connect to licensing.

 

Application Behavior is:  Launch ArcGIS Pro --> Pro splash screen appears loading --> configure licensing window pops-up --> fill in correct portal details and then enter login credentials --> splash screen shows loading again --> configure licenses window pops-up again as if in a loop.

 

Have allowed port 27000 inbound on all machines/servers. Have even added license manager and ArcGIS Pro as application exceptions. 

 

Have attempted to edit the 'service.txt' file in ArcGIS Licensing Bin directory but am unable to start licensing server again after editing this file in any way. However without edits file does contain our correct Mac address and port number 27000, so not sure if being able to edit it would help any way. 

 

 

Looking for other ideas! Some way to clearly prove that networking is the issue would be great! Thanks! 

Outcomes