AnsweredAssumed Answered

Explode tool removes features in ArcGIS Pro

Question asked by Joel.McKechnie_qgsp on Nov 8, 2018
Latest reply on Sep 23, 2019 by SHarris-esristaff

I need to explode all multi-part features in a feature class, editing in arcgis pro 2.2.3 (I want to avoid creating a new feature class using the multipart to singlepart).


Selecting all features, while the modify features > explode tool is active, still selects single-part features. If I run the tool on this selection, some features are removed, some multi-parts are not exploded and single-part features that it has selected as multi-part still appear as multi-part...


The same workflow in arcmap 10.5.1 worked perfectly, and I never had any of the issues described.


My solution at the moment is to run the multi-part to single-part tool, and use the output to select features containing the exploded layer before exploding.


Has anyone else experienced this? Is this a bug or am I doing something incorrectly to cause this?


Thanks in advance