AnsweredAssumed Answered

Field Calculator vs Calculate Field in Pro

Question asked by Dcamrine on Oct 22, 2018
Latest reply on Oct 24, 2018 by abeck_TREKK

Workflow: I have a polygon layer and a point layer with 90,000 points. I used to be able to use "select by location" to select the points within each polygon... open the points table, right click on the target field open field calculator, then type in "Area 1" in the box and then only the selected points would have "Area 1" added as a record in the target field.

 

In pro I can do the select by location but when i right click it the target field it now goes Calculate field and defaults to python 3...

 

I tried AREA= !Area! = "Prairie" with blank codeblock, the expression is valid but when i run it nothing is added to the 

target column in the point layer to the selected records. 

 

I've been out of the GIS world for a year because my roles changed at work but this seems really simple, or at least it used to. 

 

I also tried just entering 'Prairie' in the expression block but it is read and the expression is invalid.

 

I changed it to SQL and tried "Prairie"..didn't work 

 

I have never head of Arcade but it reminds me of the language in "R" 

 

I simply want to add a text value to a text field based on the selected records.  

 

 

Why did they get rid of the field calculator? 

Outcomes