AnsweredAssumed Answered

Script Tool Error Icon No Message

Question asked by Dane_Stephenson on Oct 22, 2018
Latest reply on Oct 22, 2018 by Dan_Patterson

I have a python script tool stored in a Toolbox on a network accessible drive opened and executed in ArcCatalog.  It has 5 User Parameters.  The tool uses the User Parameters to copy a template folder containing a template GDB and MXD to a new location, rename both the GDB and MXD based on parameter entries, and resources the layers within the MXD to the GDB in its new location.  It has functioned without error for over a year.  Users open it in ArcCatalog on their PC and execute it as necessary.

 

However, there is now one user who is experiencing an error.  Immediately upon opening the tool, there is an error icon above the first parameter that does not provide the typical error message (explanation).  Nothing. If you attempt to populate the parameters and execute the tool, there is just an immediate dialog that says "Error" with the Caution Symbol (Yellow Triangle with Exclamation Point).  No other user is experiencing this.  Everyone else is capable of executing the exact same tool in the exact same location as usual.  The first parameter is a string, required, with a value list to choose from.

 

Her PC is a Windows 10 64-bit OS with ArcGIS10.5.1 and Background Geoprocessing installed (Everyone else has the same OS and either 10.5 or 10.5.1 installed).  Any insight/suggestions to help resolve the issue are welcomed and appreciated.

Attachments

Outcomes