richardkingston

ArcGIS 10.4 server Linux installation not working

Discussion created by richardkingston on Aug 22, 2018
Latest reply on Aug 28, 2018 by richardkingston

Hi,

 

I have tried to find a similar discussion on here where some one else has had the problem of the installation not installing any files in the installation directory despite having 755 set as the permission. I do get an install.dir directory created in /tmp but nothing written to /opt/arcgis Here's the output when I run the install:

 

[mfhssrpk@arcgis ArcGISServer]$ /home/MFHSSRPK/ArcGISServer/ArcGISServer/Setup -m silent -l yes -a /home/MFHSSRPK/ArcGISServer/ArcGISServer/licence.prvc -d /opt/arcgis
========================================================================
ArcGIS 10.4.1 for Server Diagnostic Tool

Hostname: arcgis.its.manchester.ac.uk
========================================================================

DIAG000: Check for installation as root [PASSED]
DIAG001: Check for 64-bit architecture [PASSED]
DIAG002: Check OS version [PASSED]
DIAG003: Check hostname for invalid characters [PASSED]
DIAG024: Check /etc/hosts for hostname entry [PASSED]
DIAG004: Check installed packages [PASSED]
DIAG005: Check system limits [PASSED]
DIAG006: Check OS patches [N/A]
DIAG008: Check HTTP port [PASSED]
DIAG009: Check HTTPS port [PASSED]
DIAG010: Check Xvfb ports [PASSED]

------------------------------------------------------------------------
There were 0 failure(s) and 0 warning(s) found:

 

[ArcGIS 10.4.1 for Server Installation Details]
UI Mode..................silent
Agreed to Esri License...yes
Authorization File......./home/MFHSSRPK/ArcGISServer/ArcGISServer/licence.prvc
Installation Directory.../opt/arcgis/server

Starting installation of ArcGIS 10.4.1 for Server...
JRE libraries are missing or not compatible....
Exiting....
...ArcGIS 10.4.1 for Server installation is complete.

You will be able to access ArcGIS Server Manager by navigating to http://arcgis.its.manchester.ac.uk:6080/arcgis/manager.

 

Has anyone else overcome a similar problem?

 

Thanks,

Richard

Outcomes