AnsweredAssumed Answered

Is it a bug for 3D View?

Question asked by tms2003 on Jul 11, 2018

Is it a bug for 3D View?

I want show a path layer in 3d View.My Code like this:

 

 

 

 

var map = new Map({
layers: [stamenTileLayer]
, ground: "world-elevation"
});

 var view = new SceneView({
container: "viewDiv",
 map: map,
center: [0, 30],
 zoom: 3
 });

var hwyRenderer = {
type: "simple", // autocasts as new SimpleRenderer()
symbol: {
type: "simple-line", // autocasts as new SimpleLineSymbol()
width: 1,
color: [64, 255, 0]
}
};

 

var operationalLayer = new FeatureLayer(

{
url:"http://map.510link.com:6080/arcgis/rest/services/incar2017/MapServer/29",
renderer: hwyRenderer


});

map.layers.add(operationalLayer, 1);


});

 

 

and I get this picture

 

error picture with some path lose

 

you can find some path dismiss.with error in chrome:

init.js:288 [esri.views.3d.layers.graphics.Graphics3DSymbolLayer] LineSymbol3DLayer geometry failed to be created (no paths were defined)

 

 

 

but,when I change it to 2D View,like this:

 

var view = new MapView({
container: "viewDiv", // Reference to the scene div created in step 5
map: map, // Reference to the map object created before the scene
zoom: 4, // Sets the zoom level based on level of detail (LOD)
center: [0, 30] // Sets the center point of view in lon/lat
});

 

It's ok like this:

the right picture

so ,you can find many path than 3D View.

 

Is it a bug for 3DView?I try to change to no ground,but it still exists,Why,and how can change it?

Outcomes