dougbrowning

Empty Data Frame issues

Discussion created by dougbrowning on Jul 11, 2018
Latest reply on Jul 12, 2018 by mvolz47

Posting this here since there is strangely no ArcMap group.

 

We had a Feature Service that we completely changed the structure of but kept the endpoint and name the same.

 

Users that had the service in their MXDs now have corrupted maps.  It complains about the Data Frame and will never open - unless you do the old disconnect from the network trick.  I wrote a Python script to fix it but the script also requires the user to be disconnected (when connected it says dataframe list is None but disconnected it works).

 

Issue is after the fix script removes the old layer and adds the new one the map is staying corrupted.  The "fixed" map has an extra Data Frame called Layers that is active but totally blank.  (note this is also true of the original corrupted map)  Python cannot even see it (will not show up on a data frame list).  I can right click remove in ArcMap - but it does nothing.  Just black screen for a sec then it is still there.

 

 

I tried MXD Dr on it and that actually does seem to fix it - but only after the Python script fixes the links, before that it just hangs.  But we have hundreds so that is not really practical.

 

Any ideas to try? 

 

I have tried all my tricks and nothing.  Changing services has broke maps on me before but I do not remember seeing this phantom data frame before.

 

Thanks a lot

 

Original Error

Attachments

Outcomes