AnsweredAssumed Answered

Customized Quickreport 10.2.7 app fails when trying to build

Question asked by agol.ig.ky on Jul 5, 2018
Latest reply on Jul 9, 2018 by agol.ig.ky

Hi,

 

I have an app based on the quickreport template 10.2.7, which has been customized(some functionality added, and some functionality removed). When i try to build the app using Appstudio for Desktop(cloud make) i get the following error:

I have tried to build it locally aswell and get the same error:

 

c:/users/kamrany/downloads/android-ndk-r10e-windows-x86_64/android-ndk-r10e/toolchains/arm-linux-androideabi-4.9/prebuilt/windows-x86_64/bin/../lib/gcc/arm-linux-androideabi/4.9/../../../../arm-linux-androideabi/bin/ld.exe: internal error in do_fill_plt_entry, at /s/ndk-toolchain/src/build/../binutils/binutils-2.25/gold/arm.cc:7805
collect2.exe: error: ld returned 1 exit status

Makefile:78: recipe for target '..\..\Output\android\libAppStudioApp.so' failed

mingw32-make: *** [..\..\Output\android\libAppStudioApp.so] Error 1

Build Failed.

 

I have attached the logfile from the local make.

 

Does anyone know what causes the error? And how to solve this?

 

Any help would be appreciated.

Attachments

Outcomes