AnsweredAssumed Answered

Impossible to start portal after installing 10.5.1

Question asked by jlengrand_skyai on Jun 11, 2018
Latest reply on Jun 11, 2018 by jlengrand_skyai

Hi there, 

 

We are trying to install our first ESRI site. 

 

I have used the entreprise builder, and everything is setup on the same machine.

 

I have been able to setup the server and the first web adaptor, but for some reason I have been unable to ever start the portal.

 

This is the stack trace I get in the logs when starting the portal:

 

esri@esri:~/arcgis/portal$ cat usr/logs/portal.log
Jun 11, 2018 8:19:34 PM com.esri.arcgis.portal.impl.Main c
INFO: Copying config file from /home/esri/arcgis/portal//etc/portal-config.properties to /home/esri/arcgis/portal/framework/etc/portal-config.properties
Mon Jun 11 20:19:35 UTC 2018 JMXServerContoller.getJMXConnector() failed to return connection - port not configured1577:10
Mon Jun 11 20:19:35 UTC 2018 JMXServerContoller.getJMXConnector() failed to return connection - port not configured1577:11
Mon Jun 11 20:19:35 UTC 2018 JMXServerContoller.getJMXConnector() failed to return connection - port not configured1577:11
WARNING: Could not connect to Log service. Writing log message to console.
<Msg time="2018-06-11T20:19:35,314" type="FINE" code="209511" source="Portal" process="1577" thread="1" methodName="" machine="" user="" elapsed="">Copying customization files.</Msg>
Mon Jun 11 20:19:35 UTC 2018 JMXServerContoller.getJMXConnector() failed to return connection - port not configured1577:11
WARNING: Could not connect to Log service. Writing log message to console.
<Msg time="2018-06-11T20:19:35,319" type="WARNING" code="209512" source="Portal" process="1577" thread="1" methodName="" machine="" user="" elapsed="">Processing customization line '/webapps/arcgis#home/js/arcgisonline/config.js'.</Msg>
Mon Jun 11 20:19:35 UTC 2018 JMXServerContoller.getJMXConnector() failed to return connection - port not configured1577:11
WARNING: Could not connect to Log service. Writing log message to console.
<Msg time="2018-06-11T20:19:35,320" type="FINE" code="209513" source="Portal" process="1577" thread="1" methodName="" machine="" user="" elapsed="">Checking if customization file exists at templatePath /home/esri/arcgis/portal/framework/template/filetokens/webapps/arcgis#home/js/arcgisonline/config.js.</Msg>
Mon Jun 11 20:19:35 UTC 2018 JMXServerContoller.getJMXConnector() failed to return connection - port not configured1577:11
WARNING: Could not connect to Log service. Writing log message to console.
<Msg time="2018-06-11T20:19:35,397" type="DEBUG" code="9999" source="Portal" process="1577" thread="1" methodName="" machine="" user="" elapsed="">java.lang.Exception: Cannot read from directory path '/home/esri/arcgis/portal/usr/arcgisportal'. Please check that the location is valid and that the Portal service account has permissions to the location.
at com.esri.arcgis.portal.admin.core.util.ConfigUtil.validateDir(ConfigUtil.java:272)
at com.esri.arcgis.portal.admin.core.util.ConfigUtil.validateAndCreateStore(ConfigUtil.java:358)
at com.esri.arcgis.portal.impl.NodeAgent.install(NodeAgent.java:141)
at com.esri.arcgis.portal.impl.Main.c(Main.java:268)
at com.esri.arcgis.portal.impl.Main.main(Main.java:315)
</Msg>
Mon Jun 11 20:19:35 UTC 2018 JMXServerContoller.getJMXConnector() failed to return connection - port not configured1577:11
WARNING: Could not connect to Log service. Writing log message to console.
<Msg time="2018-06-11T20:19:35,400" type="INFO" code="209517" source="Portal" process="1577" thread="1" methodName="" machine="" user="" elapsed="">Installing all the observers.</Msg>
NodeAgent loaded observer 'LogServiceObserver'.
NodeAgent loaded observer 'ConfigObserver'.
NodeAgent loaded observer 'Portal Upgrader'.
NodeAgent loaded observer 'PatchObserver'.
Mon Jun 11 20:19:35 UTC 2018 JMXServerContoller.getJMXConnector() failed to return connection - port not configured1577:11
WARNING: Could not connect to Log service. Writing log message to console.
<Msg time="2018-06-11T20:19:35,457" type="INFO" code="218000" source="Portal" process="1577" thread="1" methodName="" machine="" user="" elapsed="">No patch file found, skipping application of patch at startup.</Msg>
Mon Jun 11 20:19:35 UTC 2018 JMXServerContoller.getJMXConnector() failed to return connection - port not configured1577:11
WARNING: Could not connect to Log service. Writing log message to console.
<Msg time="2018-06-11T20:19:35,457" type="FINE" code="217000" source="Portal" process="1577" thread="1" methodName="" machine="" user="" elapsed="">Registering 7Zip with the sharing web application.</Msg>
Mon Jun 11 20:19:35 UTC 2018 JMXServerContoller.getJMXConnector() failed to return connection - port not configured1577:11
WARNING: Could not connect to Log service. Writing log message to console.
<Msg time="2018-06-11T20:19:35,483" type="INFO" code="209518" source="Portal" process="1577" thread="1" methodName="" machine="" user="" elapsed="">Installing all the plugins.</Msg>
NodeAgent loaded plugin 'ProcessMonitor'.
NodeAgent loaded plugin 'HAMonitor'.
NodeAgent loaded plugin 'UninstallPlugin'.
Mon Jun 11 20:19:35 UTC 2018 JMXServerContoller.getJMXConnector() failed to return connection - port not configured1577:1
NodeAgent loaded plugin 'LogFileLimiter'.

Checking in the file system, I have indeed no portal/usr/arcgisportal folder.

 

I tried to uninstall / reinstall the entreprise builder, without success. I have also tried to install the portal only, without success either. Even after redownloading the whole installer files.

 

I do not get why the folder isn't there right after installation, and haven't found any resource online about the issue.

 

Any help would be largely appreciated.

Outcomes