AnsweredAssumed Answered

Sometimes elevation data is wrong

Question asked by tuanpa90 on Jun 5, 2018

I used the structure below to retrieve the data of the elevation

 

POST /arcgis/rest/services/Tools/ElevationSync/GPServer/Profile/execute HTTP/1.1
Host: elevation.arcgis.com
Cache-Control: no-cache
Postman-Token: 3229e481-ffba-4610-bb0f-a2332924eb4d
Content-Type: multipart/form-data; boundary=----WebKitFormBoundary7MA4YWxkTrZu0gW

------WebKitFormBoundary7MA4YWxkTrZu0gW
Content-Disposition: form-data; name="f"

json
------WebKitFormBoundary7MA4YWxkTrZu0gW
Content-Disposition: form-data; name="token"

oO6ctwMghV0WsZQni3ELP_wWfIcVukvhySUoKTLs4f6eNeiSmPCHBL9SOlfmb_hOEqqvgQj_TWkA7lzXp8LmvDZmzngP4Sk3F8hmv4GA0S_scR52xwMq2mMS4315x_toKuA5UPh1d9x914u4VsLB-Q..
------WebKitFormBoundary7MA4YWxkTrZu0gW
Content-Disposition: form-data; name="returnZ"

true
------WebKitFormBoundary7MA4YWxkTrZu0gW
Content-Disposition: form-data; name="DEMResolution"

FINEST
------WebKitFormBoundary7MA4YWxkTrZu0gW
Content-Disposition: form-data; name="ProfileIDField"

OID
------WebKitFormBoundary7MA4YWxkTrZu0gW
Content-Disposition: form-data; name="InputLineFeatures"

{
"displayFieldName": "ProfileSet",
"geometryType": "esriGeometryPolyline",
"spatialReference": {
"wkid": 4326
},
"fields": [
{
"name": "OID",
"type": "esriFieldTypeOID",
"alias": "OID"
},
{
"name": "Shape_Length",
"type": "esriFieldTypeDouble",
"alias": "Shape_Length"
}
],
"features": [
{
"attributes": {
"OBJECTID": 1,
"Shape_Length": 100
},
"geometry": {
"paths": [
[
[
153.299811,
-27.640068
],
[
153.302805,
-27.656461
]
]
],
"spatialReference": {
"wkid": 4326
}
}
}
],
"exceededTransferLimit": false
}
------WebKitFormBoundary7MA4YWxkTrZu0gW--

 

Sometimes when I receive incorrect data, please check 2 files which I have attached.

Attachments

Outcomes