AnsweredAssumed Answered

Know why Table To Relationship Class Tool isn't working for me?

Question asked by Beibhin91941 on Jun 4, 2018

I have a relationship table in ArcPro that I've imported from another GIS system (that we're migrating from). The table defines a many to many relationship between two feature classes (Laterals and Parcels). In ArcPro 2.1.2 using the Table To Relationship Class tool, I've been trying to create a relationship class using this table and the two feature classes. But even though it reports that it is successful, and rows get created in a relationship class, the relationships don't actually appear to be created.

 

As a test, I tried reducing this to it's simplest form, by creating a copy of the table and the feature classes that each have just two rows. Incidentally it's not imperative that I have "Attribute Fields" in the relationship class, but since the Table To Relationship Class tool forces me to have at least one, I did choose one( service_point_id) which is null in the examples.

 

I would expect when I run this tool that in the resultant relationship class, latid and apn would be populated, (and I guess I'd have to subsequently migrate that to objectID and then migrate it to GlobalID). But in fact, though the table and rows get created, the foreign key fields have null values.

 

Anyone know what the problem is here?

Outcomes