AnsweredAssumed Answered

Can't get returnExtentOnly option to work?

Question asked by flspat on May 24, 2018
Latest reply on May 25, 2018 by flspat

Hi All:

 

According to the REST SDK help page, MapService\Layer\Query supports the returnExtentOnly option at 10.3.1+ for on-premise servers when the layer's "supportsReturningQueryExtent" is true.  The WYSIWYG REST Query form has a radio button for the values as well.  However I can't seem to get this option to return anything at all.  Is the documentation off, something else wrong? 

 

Follow these steps on the sample server: 

 

1. Open the top level REST info for the server: Folder: / 

 + verified server is 10.6

 

2. Open the SampleWorldCities\Continent info Layer: Continent (ID: 1) 

 + verified supportsReturningQueryExtent = true (both in html and json output)

 

3. Open SampleWorldCities\Continent\Query Query: Continent (ID: 1) 

   + set where for a specific feature ie : CONTINENT='South America'

   + click Returns Extents Only to True radio button

   + click Query (Get) button

 

Result is definitely not a simple extent.  

 

   + click Return Geometry to False radio button

   + click Query (Get) button

 

Result is just the display attribute

 

   + click Return Count Only to True radio button (this is mentioned in the help) 

   + click Query (Get) button

 

Result is just the count number.  

 

So is the help wrong or does this service not support the option even though it says it does or am I doing something wrong or have the wrong expectation of what this does?  I tried some other map services and get the same result so it doesn't seem particular to the SampleWorldCities, I used that as a simple example since everyone has it on their server. 

 

Thanks

Fred

 

 

 

 

Outcomes