AnsweredAssumed Answered

Layers within feature service not fully displaying in Desktop after column edits made in Portal

Question asked by hwhitenack@nps.gov_nps on May 16, 2018

Hello,

 

Yesterday afternoon I was working on a Feature Service containing 4 separate layers in Portal as well as 4 tables which have relations with the layers. One of our users had a need to add in a new field/column to 3 of the 4 layers. I used the instructions found on "Add a Field" to make the additions. The field I added in was a length 10 string and was the same across all 3 of the 4 edited layers. The 4th layer was unmodified.

 

The issue I'm running into has to deal with viewing and opening the Feature Service in ArcGIS Desktop 10.XX and ArcPro. With ArcGIS Desktop I run into a problem when trying to open the Feature Service using the typical workflow of File -> Add Data -> Add Data From ArcGIS Portal -> My Groups -> (our group) -> (Feature Service in question). The Feature Service is still available but when you add the Feature Service in, only 1 of the 4 layers is added. This single layer is one the layers which has the added field from yesterday but the 3 other layers including the unedited layer are not displayed.

 

Similarly in ArcPro I can see the Feature Layer that I made edits to, I can see the 4 layers and 4 tables but when I add the Feature Layer to the map only 1 of the 4 layers is added (the same layer described above) and all 4 tables. However, if I right click individual layers and add to map the the layers correctly drop in as expected. 

 

Within Portal itself I can see the Feature Layer modified yesterday and when I open it all 4 layers are displayed correctly with the 3 edited layers reflecting the column additions I made yesterday. I have not made the same column changes to our Web Map yet but I don't think that would be an issue. I deleted the added columns and tried to see if that made a difference but I'm still running into the same problem.

 

Do you know what may be causing my issue? I'm a bit new with the Portal interface so it may be something simple or a setting I'm missing but I'm not sure.   

 

Best and much appreciated,

 

Henry

Outcomes