AnsweredAssumed Answered

Insights in AGOL - "We couldn't display all features"

Question asked by dan_h_b on May 3, 2018
Latest reply on Jul 9, 2018 by Lynn_Carlson

I have a file geodatabase with a single feature class (polygon) which I have zipped and uploaded to my organisation's AGOL account and created a hosted feature layer.

There are just 11 polygons in my feature class.

I can view the data in a web map.

I can view the data in ArcMap.

I have tried adding it to Insights but it won't display all polygons when I add it to a map.  Some polygons will only display if I zoom in really close.  Some polygons won't display at all.  The 11 polygons encompass all the water areas around the UK, so they aren't small polygons.

 

If I open the dataset as a table in Insights, I can see all the records.

 

The same dataset was working a few weeks ago when I last used it in Insights.  The dataset has not been edited since.  Has there been an update to AGOL or Insights in the last few weeks?

 

The error I get:

Image showing the "We couldn't display all features" error in Insights.

 

If I click for more information, it just tells me how many features are being displayed.

 

The data is in wgs84.

 

Things I have tried.

  1. Chrome (v66) and Internet Explorer 11.
  2. Cleared cookies & cache.
  3. In ArcMap, checked for geometry errors - there are none.
  4. Saved the feature class to a new fgdb and added it to AGOL.  Same error.
  5. Exported the feature class to a shp file, zipped this and added it to AGOL.  Same error.
  6. Deleted the .prj file for the shp file and run the "Define Projection" tool in ArcMap and set it to wgs84.  Same error
  7. Re-projected the dataset to Web Mercator. Same error
  8. Checked the extent of the dataset.  This is correct.  As shown by the automatic thumbnail created in AGOLAGOL Thumbnail
  9. Re-created the dataset from scratch.  Same error.
  10. In the settings tab for the hosted feature layer in AGOL, I've optimised the layer drawing.  Same error.

 

I am at a total loss for what to do next.  Any ideas?

Is this just a glitch with Insights?  It's just confusing as the same dataset was working a few weeks ago.

 

Thanks

Outcomes