AnsweredAssumed Answered

Not sure if Enterprise configured correctly

Question asked by joshsaad on Apr 26, 2018

I'm not sure if I configured Enterprise correctly.  I've decided to use a multi-server environment with a GIS server and an Image Server.  We have multi-year aerial images, and are implementing drone solutions, so I'd like to offload image processing and storage to the Image Server.

 

I installed Portal/Server on one server, and Image Server on another.  I configured three Web Adapters (server, portal, and image) on the first server.  I installed Data Store on both servers, with a relational store on the first server, and a tile cache store on the image server.  I configured a Raster Store on the image server using a network file share hosted by that server.  I followed all of the steps in configuring Portal to use the image server for raster analysis.

 

Everything seems to be working, but Drone2Map crashes when I try to upload some test data as an imagery layer to my Enterprise Portal.  Event Viewer shows the crashes as being caused by KERNELBASE.dll.  To troubleshoot I've also tried uploading from a virtual workstation and I get the same result.  I have a feeling that it's because the image server is throwing an error and Drone2Map doesn't know how to handle it.

 

To further troubleshoot, I also tried uploading imagery as a map service to Portal from ArcGIS Pro, and performing raster analysis from the web map.  When I select a layer to perform analysis on, nothing populates the drop-down list.  This makes me wonder if Raster Analysis is really working in the Portal.

 

I was thinking that I may need to add the Image Server to the main server's cluster, but I figured federation would handle all of that.  Before I get too deep in the weeds though I just wanted to check online to see if anyone else has any ideas.  Thanks!

Outcomes