AnsweredAssumed Answered

Why does Append hang on "Analyzing data... "

Question asked by _@sbanana99 on Apr 25, 2018
Latest reply on May 3, 2018 by _@sbanana99

I have a hosted feature layer that I'm unable to append data to.  The process hangs on "Analyzing data..." and never recovers.  There was no error message.  The layer has an extremely large number of fields in the schema, 562 to be exact. We would liked to have reduced the number of fields by creating separate Surveys or using a Repeat strategy, but the users would have none of it.  (They are performing audits on crews at job sites, and there could be thousands of combinations of what specific items they'd rate on a single audit, with a weighted total score calculated at the end.) Is the number of fields likely the root cause?  What is the limit?  I tried using Excel and a file geodatabase as the data source, but neither worked.  The schema and field mapping is exactly the same as the hosted feature layer.

 

We are in this predicament because we made additional choices available in some select_one questions and needed to republish. We will need to do this again in the future.  There was no change to the schema to force an overwrite and loss of data.  However when publishing, it hung and never recovered, also without an error message.  So, we were forced to publish a new Survey and create a new hosted feature layer.  Now we are trying to consolidate the data into one layer.

Outcomes