AnsweredAssumed Answered

Tabulate Area 2: Results Seem Off

Question asked by CalEmys on Apr 14, 2018
Latest reply on Apr 20, 2018 by CalEmys

Hi all.  I'm using the Tabulate Area 2 tool to determine the area of land use types within buffers (1km) around many points at the center of wetlands.  I think I've finally gotten the output I want, but there's a few things in the output that make me question it.  

I have a raster land use file (30m resolution) that I downloaded from the internet that is in the projected (I think?) coordinate system: WGS_1984_Lambert_Azimuthal_Equal_Area.  I also have a polygon shapefile of the wetlands, that I made.  I projected this to the same coordinate system as the land use file.  I then made a centroid point layer for the wetlands layer because I wanted the 1km buffers to be the same size because buffers around the wetlands were not equal size/shape.  After this, I used the Tabulate Area and Zonal Histogram tools to try to determine either the area or number of pixels of land use types from the raster layer in each of the wetland point buffers.  These methods either provided outputs with missing data (i.e., not all of the buffers were accounted for) or very unequal numbers of total pixels for each buffer, respectively.  So, after reading several other posts, I tried the Tabulate Area 2 tool, thinking that my problem may have been due to so many overlapping buffers.  This, and using the "Object ID" as the zone field rather than my own identification code which I'm thinking might have been too long for the tool to detect them as being dissimilar, may have solved my problem.  (Many buffers were identified as things like "Colonsay 0.28km a" and "Colonsay 0.28km b" and are only different at the very last letter.  I'm wondering if that was too many 'digits'?)

So, in the output from the Tabulate Area 2 process all of the buffers are accounted and it looks mostly good.  I have a few concerns though that I'm not sure how to reconcile. 

1)  On the first use of this tool, I got some values of "<null>" but I tried it again and on the second use those values were 0.  I'm not concerned about them being 0 as that pixel type was uncommon across the landscape, but I'm somewhat concerned about the null values, even if I didn't get that every time I used the tool. 

2) When I sum the total area calculated for each buffer (a circle with 1km radius) it varies per buffer and doesn't equal the size of the buffer.  i.e., the buffers are all 3141593 square meters, but the total areas as calculated by the Tabulate Area 2 tool range from 3132900 to 3153600 square meters.  

 

I'm not sure if the discrepancies between the actual area of the buffers and the sum area calculated by the Tabulate Area 2 tool are due to the tool including or excluding pixels that lie on the edge of the buffer circle, and thus are not necessarily important to worry about, or if this is a sign that the output is not correct and I've done something wrong along the way.  

 

Thanks for any help!

Outcomes