AnsweredAssumed Answered

Solution: Print GP service not printing cached basemap (AGS 10.5.1)

Question asked by rastrauch Champion on Apr 4, 2018
Latest reply on Jun 18, 2018 by jamiew0519
  • New setup:  ArcGIS Server 10.5.1  (non-federated)
  • Basemaps are non-secure cached services (JPEG) using the v2 of the compact cache format
  • "operational" layers are dynamic,  (tried adding a cached layer just to test but it didn't like that)
  • I have a proxy in place, and it is working for the web site and for accessing my secure services
  • All layers are in Alaska Albers, so reproject is not involved.


All layers show on my JS web page as expected.  I set up the 10.5.1 print GP service following instructions found 

and the print service itself seems to be working. (currently set to sync, received AGS log error if async, even though I am not using Portal or Pro)


I think I have everything setup the same way as I do on my 10.2.2 AGS server. 

-The 10.2.2 server prints the base map with no issues.

-The 10.5.1 server prints all except the based map.


I have seen several threads about basemap not printing in Flex app, but this is JS.  The other thread I have reviewed is Cached basemap not fully loading in layout view but there was no answer int hat thread yet.


BTW - I am currently working with JS v3.10, which I know is old, but does work with every thing else so far, except maybe printing basemaps in 10.5.1.  I haven't taken the time to update my JS to a newer version....that may take some work since the html format messes up...and I'm short on time.  I have not yet played with things in the JS sandbox online since our 10.5.1 servers are still inside the firewall.  


I think we have all the patches that may effect this install (the GP one).  I see there is a Basemap patch for Portal, but again, this is ArcGIS Server, non-federated, so I do not think that applies.  For the record,below is the result of "check for updates"



Any help is appreciated.  Thanks



EDIT:  some additional testing, which leads me to think this is a bug.


Above is based on:

  1. AGS 10.5.1 custom GP Print service
  2. AGS 10.5.1 tiled map service  in 10.5.1 compact format (v2)
  3. a working proxy


  • If I switch out #1 above with the the working GP Print service from 10.2.2 ... does not work
  • If I switch out #1 and the #2 for the same on 10.2.2 ...does not work
  • if I leave #1 as 10.5.1 and switch out #2 with the map service from 10.2.2...IT WORKs


So, I think is it an issue with the cached map serivces in 10.5.1 (I tried more than one cached map service).  I am not sure if it is the cached map service in general of or  the v2 compact format.


I will put in a tech support ticket and report back....but if anyone else has run into this issue and/or found a solution, I would appreciate the info.  Thanks