AnsweredAssumed Answered

Can't upgrade API to 1.4 - Conflict with Anaconda

Question asked by PSLarkin_SpokaneCounty on Mar 30, 2018
Latest reply on Apr 6, 2018 by JSellers-esristaff

I'm encountering an odd error when following the instructions for upgrading the package for Pro (2.1.2) located here: Install and set up | ArcGIS for Developers. I'm upgrading the Python API from 1.2.5


Using the Python Command Prompt packaged with the Pro installation leads to the error (see attachment): 'Package not found: 'arcgis' Package 'arcgis' is not installed in F:\Anaconda3\envs\arcgispro-py3 

 

There appears to be a conflict between my Anaconda installation and the conda installation packaged with ArcGIS Pro. It is odd that the Python Cmd Prompt doesn't recognize a package in the Pro environment because it is active. I tried adding a system and user path variable: "C:\Program Files\ArcGIS\Pro\bin\Python\Scripts". That didn't help. 

Has anyone experienced this and have any ideas? 

David Wynne

Joshua Bixby

Attachments

Outcomes