AnsweredAssumed Answered

Can't convert ESRI Metadata to ISO19139

Question asked by roelandtn on Mar 20, 2018

Hi,

 

I extracted metadata from an SDE using arcpy.

I tried to convert it to ISO19139 using arcpy and the script below.

 

If I load the raw metadata in GeoNetwork it tells me unknownSchema. I tried to convert it using arcpy.ESRITranslator_conversion() and ESRI_ISO2ISO19139.xml translator. In that case, GeoNetwork says BadSchema.

 

I'm a bit stuck. Any idea how to fix that ? Am I missing something ?

 

Best regards,

Nicolas Roelandt

 

Here is the script  used :

#!/usr/bin/env python
# -*- coding: utf8 -*-

 

import os, sys, arcpy

 

rep_projet = ur"D:/Projets/PP/GeoNetWork/test/"

 

source_md_format_iso = rep_projet + "ADM_chef_lieu_formatESRI.xml"

 

rep_install = ur"C:/Program Files (x86)/ArcGIS/Desktop10.5/Metadata"
translator =  os.path.join(rep_install, u"Translator", u"ESRI_ISO2ISO19139.xml")

rep_sortie = rep_projet + "sorties_HTS_10.5"

 

arcpy.ESRITranslator_conversion(source=source_md_format_iso,\
                                translator=translator,\
                                output=os.path.join(rep_sortie, u"ADM_chef_lieu_ESRI2ISO19139.xml"),\
                                logfile=os.path.join(rep_sortie, u"log.log"))

Outcomes