AnsweredAssumed Answered

PostgreSQL - st_geometry error Enable Enterprise Geodatabase (10.6)

Question asked by geoinformacao on Mar 6, 2018
Latest reply on Apr 12, 2018 by vangelo-esristaff

Hi guys

 

I´m trying to Enable one PostgreSQL Database and I got one error . PostgreSQL 9.6, Linux. Portal, Server and Datastore 10.6.

 

"You must copy the latest ST_GEOMETRY library to the PostgreSQL software location. Refer to the ArcGIS help topics for more details."

 

The st_geometry was on lib folder. I´m following the instructions from HELP .

 

I´m sure my st_geometry is the latest version, so, any idea?

 

Here the full error :

 

Executing: EnableEnterpriseGeodatabase "C:\Users\myuser\AppData\Roaming\Esri\Desktop10.6\ArcCatalog\Connection.sde" C:\Users\myuser\Key\keycodes
Start Time: Tue Mar  6 16:22:57 2018
Validated authorization file.
User has required privileges for geodatabase setup.
XML support is enabled for the database instance.
You must copy the latest ST_GEOMETRY library to the PostgreSQL software location. Refer to the ArcGIS help topics for more details.

 

Connected RDBMS instance is not setup for Esri spatial type configuration.
Failed to execute (EnableEnterpriseGeodatabase).
Failed at Tue Mar  6 16:22:58 2018 (Elapsed Time: 0.59 seconds)

Outcomes