AnsweredAssumed Answered

"invalid start of json - expecting { or [" when updating 100.1.0 to 100.2.1

Question asked by salihyalcin89 on Mar 6, 2018

Hello Dear developers, 

 

I am developing an Android app that uses Esri Android SDK 100.1.0 version. In order to not writing credentials in code we're using basemap links like below : 

https://xyzproxy.abc.gov.tr/proxy.ashx?https://gismap.abc.gov.tr/arcgis/rest/services/Satellite_2017_WM/MapServer

When using Esri Android 100.1.0 version, everything works like a charm. After updating SDK to 100.2.1 basemap is not loading and failed error say that invalid start of json - expecting { or [  

 

How can I resolve this issue. Thanks for all. 

 

Dan O'Neill

Outcomes