AnsweredAssumed Answered

|FIXED| CityEngine SLPK and Portal for ArcGIS

Question asked by geoinformacao on Mar 5, 2018
Latest reply on Mar 18, 2019 by roc168

Few months ago I was trying to publish my CityEngine Project on my Portal as slpk to create 3D Webscenes . I got an error and I though it was because my Portal was 10.4.1 and my CityEngine was 2017.


So, now I have everything updated. Cityengine 2017.1, Portal /Server(Federeted) and Datastore 10.6 on Linux.

3ws files works very well, but I want to create 3D Webscenes on my Portal (not on AGOL). My workflow:


 - Create my project on CityEngine

 - Select my Data on Viewport and Export Models > ESRI Service Layer Package (slpk).

 - Open my Portal > Content

 - Add data from my Computer and add the slpk file.


After few seconds to upload and puplish, I got a Error like " There´s a error" and it´s impossible to publish and use the project. 


I tried the same steps on ArcGIS Pro and got the same error.


My slpk works perfectly on AGOL, but it´s not a option here .



Logs from ArcGIS Server after try


SEVEREMar 8, 2018, 1:49:36 PMError executing tool. Publish Portal Service Job ID: j569ae00ab9114e17b08513f30cfedf36 : ERROR 001887: Failed to create couchdb database. ERROR: no registered nosql databases on the server. Failed to execute (Publish Portal Service).System/PublishingTools.GPServer
SEVEREMar 8, 2018, 1:49:36 PMERROR: no registered nosql databases on the server.System/PublishingTools.GPServer
SEVEREMar 8, 2018, 1:49:36 PMFailed to create couchdb database.System/PublishingTools.GPServer