AnsweredAssumed Answered

Does exporting runtime content with network datasets require Standard or Advanced ArcMap?

Question asked by Crittermap on Feb 26, 2018

Following this article, we have created a network dataset from OSM data using ArcMap 10.5. 

(BTW, I don't know if this is doable in Arcgis PRO. Only instructions I could find were for ArcMap.)

 

Create a network dataset from osm data · Esri/arcgis-osm-editor Wiki · GitHub 

 

When we get to the part where we export it to runtime content. 

 

Creating ArcGIS Runtime content—Help | ArcGIS Desktop 

 

We get an error message at this time that seems to indicate we need Standard or Advanced Desktop license: 

A Standard or Advanced product with a Network Analyst extension license is required to package networks

 

SEVERITY STATUS CODE DESCRIPTION NAME TYPE DATA FRAME
Medium Unresolved 00218 A Standard or Advanced product with a Network Analyst extension license is required to package networks NZN_NZN_nd

 

I could not find an article that specifically mentioned needing this license for this purpose. I would need that documentation to justify the upgrade for my company. 

 

I believe I reviewed developer licensing when I purchased and found that a Basic license *should* generate all the runtime content I needed, but I could have missed something. 

 

If this license is needed, is it only for this final step of exporting the runtime content? 

Outcomes