AnsweredAssumed Answered

Apply an asset package error message

Question asked by aleksandra.zietara@tronderenergi.no_TEN on Feb 20, 2018
Latest reply on Mar 13, 2018 by abhijeet

Hello, I am struggling with creating en electric utility network inside my organization. I followed steps from documentation: Get started with the Electric Distribution Utility Network Configuration—Get Started | ArcGIS for Electric and everything is configured as it should be. I am using PostgreSQL 9.5.7 database. My problem starts in the point 4.. I managed to 'Stage the Utility Network' but every time I am trying to 'Apply an asset package' I am getting errors. I have tried different configurations already but usually the error is: 

 

Running script AssetPackageToUtilityNetwork...
ArcGIS Pro 2.1.1.10257
untools 2.1.0.1
Updating schema on ElectricDistributionAssembly
Updating schema on ElectricDistributionDevice
Updating schema on ElectricDistributionJunction
Updating schema on ElectricDistributionLine
ERROR 999999: Error executing function.
The subtype already exists. [un.andreasbv.ElectricDistributionAssembly]
Failed to execute (AddSubtype).
EXCEPTION
Traceback (most recent call last):
File "C:\Program Files\ArcGIS\Pro\bin\Python\envs\arcgispro-py3\lib\site-packages\untools\common\wrappers.py", line 90, in wrapper
return func(*args, **kwargs)
File "C:\Program Files\ArcGIS\Pro\bin\Python\envs\arcgispro-py3\lib\site-packages\untools\gptools\tools.py", line 300, in run
share.schema_apply()
File "C:\Program Files\ArcGIS\Pro\bin\Python\envs\arcgispro-py3\lib\site-packages\untools\utils\shared_validation.py", line 504, in schema_apply
return self.apply()
File "C:\Program Files\ArcGIS\Pro\bin\Python\envs\arcgispro-py3\lib\site-packages\untools\utils\shared_validation.py", line 450, in apply
result = func(**kwargs)
File "c:\program files\arcgis\pro\Resources\arcpy\arcpy\management.py", line 16618, in AddSubtype
raise e
File "c:\program files\arcgis\pro\Resources\arcpy\arcpy\management.py", line 16615, in AddSubtype
retval = convertArcObjectToPythonObject(gp.AddSubtype_management(*gp_fixargs((in_table, subtype_code, subtype_description), True)))
File "c:\program files\arcgis\pro\Resources\arcpy\arcpy\geoprocessing\_base.py", line 506, in <lambda>
return lambda *args: val(*gp_fixargs(args, True))
arcgisscripting.ExecuteError: ERROR 999999: Error executing function.
The subtype already exists. [un.andreasbv.ElectricDistributionAssembly]
Failed to execute (AddSubtype).
Failed to execute (AssetPackageToUtilityNetwork).

 

As an Asset Package I am using default geodatabase ElectricDistribution_AssetPackage.gdb, I am checking both Structure and ElectricDistribution and as Input I am using Utility Network created in previous step. I am not loading data as for a now I would like to have just a scheme. 

Could anyone tell me what am I doing wrong? I believe there is some detail which stands behind the logic of Utility Network Model but as documentation describe the process quite briefly I can't figure out appropriate approach.

Outcomes