jrfishe1

Problem with "View in Google Earth" link off-WAN for cached services

Discussion created by jrfishe1 on Jan 28, 2011
Latest reply on Jan 31, 2011 by jrfishe1
Hi,

I'm having an interesting problem viewing my cached map services in google earth. If I open a link like this: http://maps.tnc.org/ecadpubprod-anon/rest/services/portfolio_anon/MapServer/kml/mapImage.kmz it works fine if I'm on my company WAN but not if I'm off it (I just get red X tiles, and if I turn on error reporting it tells me it couldn't find the images). We use "maps.tnc.org" as a public domain for our server (which can also be accessed via ecadpubprod.tnc.org if you're on our WAN),

I've unzipped the kml and opened the contents and have confirmed that it's going to links which work fine publicly. However, once I open it in Google Earth, it asks for http://ecadpubprod.tnc.org/arcgiscache/portfolio_anon/Layers/<file> instead of http://maps.tnc.org/arcgiscache/portfolio_anon/Layers/<file>, which won't work.

Does anyone know if there's a server setting where I can tell it to always use "maps.tnc.org" for these kml requests (ideally across the entire server)? I can see in Manager when I click on kml under capabilities that the web access URL starts with https://ecadpubprod.tnc.org, but I can't edit it.

I can get dynamic services or network links to work, but they're too slow for some of my data sets.

thanks!

Outcomes