AnsweredAssumed Answered

32Bit vs 64Bit- pip installs

Question asked by jhead@lakeworth on Feb 15, 2018
Latest reply on Feb 15, 2018 by jhead@lakeworth

Hello all,

 

I am experiencing an issue with python installations 32bit and 64bit.

 

ArcMap 10.5.1 (uses 32bit) however I also installed the 64bit background processing. This is great however when I install 3rd party libraries via CMD "pip install <package_name>" it loads the libraries into the 32bit python when I try to import them into IDLE (uses 64bit now because of the background processing I installed) it fails for obvious reasons (its not there)

 

All pip installs go to the 32bit Python but I need them to hit the 64bit python because that's what ArcMap is using now.

the environment variables are still the same pointing to the 64bit instance of Python27 folder unless the background processing .exe's are in a different location? I assume I need to point the pip installs to the 64bit locations...

 

successful import of 3rd party library in 32bit

 

failed import into 64Bit python

 

Note: scrapy is just an example, same result for all libraries being installed via pip

Outcomes