AnsweredAssumed Answered

Weirdness in uploading to ArcGIS Online

Question asked by wbw4sv on Feb 10, 2018
Latest reply on Feb 11, 2018 by bixb0012

I am having some very strange issues with uploading feature layers from a geodatabase file. A few months ago I uploaded a geodatabase, and everything uploaded properly. A few days ago, I tried uploading the exact same geodatabase file, and one of the layers was missing exactly two features when viewing the map in both the ArcGIS Online map viewer as well as the map on my web page. When I looked at the geodatabase in ArcMap, the features show up normally. 

 

When I got to this point, I thought to myself, "Maybe ArcGIS changed the way they parsed the data since I uploaded the first time." Then I opened the layer in ArcGIS Online (as opposed to the developers console), exported the original layers that I uploaded (which still look fine on the map) to a geodatabase and tried uploading that geodatabase to a new layer. When I did that, the features that were missing from the previous upload were present, but two other features were missing from the map. Again I looked at the exported geodatabase in ArcMap and it looked fine. 

 

I am not sure what to do at this point. I need to update the data on my layers for my application, but this is causing some problems. I've also tried repairing the geometries of the geodatabases in ArcMap to no avail. Has anyone else experienced this issue and solved it?

 

This is the order of the pics:

Current: The feature layer that I uploaded initially, a few months ago

Second: The feature layer that I uploaded a few days ago, with the same geodatabase file as the previous

Exported Geodatabase: The feature layer that I uploaded from the exported geodatabase that ArcGIS Online gave me

Attachments

Outcomes