AnsweredAssumed Answered

How to troubleshoot a dissolve that returns empty output.

Question asked by kakaufman on Feb 9, 2018
Latest reply on Feb 11, 2018 by Dan_Patterson


I have a map layer containing election district boundaries. All of the election districts are located within towns. As a learning task, I'm attempting to dissolve the boundaries of the constituent districts to create a town shape layer. I have a few statistical fields in the layer that I would like to sum when I dissolve the district boundaries.

 

I've tried using the Dissolve command, but keep finding it returns an empty table (" WARNING 000117: Warning empty output generated."). I'm also unclear on what to enter in the Output feature class field. By default the field seems to be populated with the name of another shape layer in my project, but I don't want to overwrite that layer.

 

After reading some forum posts, I thought maybe my geometry was corrupted. I tried the Check Geometry tool, which did return an error (" WARNING 000442: could not find spatial index at -1 in Westchester 2014_Town boundaries"). I also tried the Repair Geometry tool which ran successfully. However, when running the dissolve command I still am getting empty output.

Outcomes