AnsweredAssumed Answered

Multi Ring Buffer

Question asked by samanthaj.hughes on Feb 2, 2018
Latest reply on Feb 2, 2018 by wkaiser-esristaff

Hi all,

 

Creating a multi ring buffer tool - it doesn't seem to be presenting with the layer at the end?

Has anyone else had this? Does anyone have a working example they can share?

 

I have even gone back to the basic buffer example in the samples and amended the two lines of code and I still get no layer:

 

 protected override async Task<bool> OnSketchCompleteAsync(Geometry geometry)
{
var valueArray = await QueuedTask.Run(() =>
{
var g = new List<object>() { geometry, };
return Geoprocessing.MakeValueArray(g,"C:\ArcGIS\Projects\MyProject1\MyProject1.gdb\Annotation",@"500,1000,2000","Meters","Distance","All","None");
});
await Geoprocessing.ExecuteToolAsync("Analysis.MultipleRingBuffer", valueArray);
return true;
}

I have tried this in the new 2.1 SDK also to no avail.

I have a sneaky suspicion it has something to do with the buffer value syntax. Annotation is a feature class for polygons. 

 

Buffer works absolutely fine and I have got it working in arcpy. However I want the user to be able to use the cursor to pick a point on the screen rather than have a feature class with points in to "multibuffer".

 

TIA

Outcomes