AnsweredAssumed Answered

can't publish services to ArcGIS Server

Question asked by Sara_EL_MALKI on Jan 27, 2018
Latest reply on Apr 27, 2018 by Thomas_Gis_Roth

Hi guys,

 

I've already workd with ArcServer for years, and Now I've changed my laptop and needed to install the softwares all over again,

I'm using a geodatabase (PostgreSQL), and succeded to connect to it as an enterprise geodatabase,

successfully connected to ArcGIS Server and registred it my geodatabase.

(working with ArcGIS 10.2)

but once I wanted to publish a map service, an error is displayed,when trying to publish a service

I have tried to google the error but none of the tricks helped,

Error: Packaging succeeded, but publishing failed. ERROR: unable to connect to publishing tools service. Verify the serv…  because I've already gone through these stuffs, I don't remeber at all having to create roles in the server manager as that links suggest,

when I tried to give all the permissions to arcgisserver directory,

It displayed that error: (which is about that an error occured while applying the changes. access denied) when I clicked continue it gives the full control to the folder (data-store, directories-logs)

access denied

I tried to restart the publishing service but it failed showing that arror:

restarting Publishing service

and just then I discovered that all the system services of the server are empty of tools:

empty services

 

I am stuck right now, please if you pass by here tag someone who can help me in this, because the docs contains a lot of text meanwhile I need sceenshots to explain me the possible solutions.

(I am on local machine, so my server is localhost & I've configured the web adaptor with the server)

 

Derek Law Rebecca Strauch, GISP Robert Scheitlin, GISP 

Outcomes