AnsweredAssumed Answered

Attribute Popup Disappearing While Editing

Question asked by andrew.southern@Franklintn.gov_franklin on Jan 23, 2018
Latest reply on Aug 2, 2018 by KCullen-esristaff

I have recently noticed that the attribute popup window is disappearing while attempting to edit attribute data in web maps.  What's happening specifically is when a web map is loaded and a feature selected, the edit button at the bottom of the popup is selected and for the first feature edited the popup remains and everything works as expected.  However, once that edit is saved/closed and another feature is selected, when the edit button is selected at the bottom of its attribute popup window the popup disappears and the feature is no longer selected.  You have to select the feature again from the map in order to bring the popup back up.  If the web map is reloaded the same behavior occurs with the first edit acting as expected, any additional edits to other features results in the attribute popup disappearing and the need to select the feature again.

 

It's not a serious problem but it is inconvenient, particularly if you have a lot of features that are all symbolized the same way and have to re-find the feature that you were attempting to edit.  For now I'm working around the issue by making edits in the attribute table itself rather than via the popup.  I thought perhaps this was an issue with the particular hosted feature service the edits were being made against but the same issue occurred when testing against a different feature service completely.

 

Has anyone else experienced this bug recently? 

Outcomes