AnsweredAssumed Answered

Lost feature class data records while editing; error message "Could not load data from data source. If you can correct the problem, press the refresh button to reload data".  While editing point

Question asked by marincollotz on Jan 18, 2018
Latest reply on Jan 19, 2018 by marincollotz

Lost file geodatabase feature class data records while editing; error message "Could not load data from data source. If you can correct the problem, press the refresh button to reload data".

 

While editing point feature class attributes, got the above error message after saving edits.  I  stopped editing, closed the table and re-opened it.   5 of 58 features were gone; these features were not selected or being edited when the error occurred. 

 

Interestingly, there are still 5 completely blank records in the table (with no ObjectID).  When I selected all records from the Table Options and looked at the selected records ("Show selected records"), the blank records were also shown in the selection color, and the text below table read:  "58 out of 53 selected" (see image below).


I have read Knowledge Base article 000012169 ("Error: Could not load data from data source. If you can correct the problem, press the refresh button to reload data"), and can eliminate A ("feature class exceeds 2 GB"), C ("Username authentication configuration") and D ("Object name begins with a number, contains a space, or contains a special character"). I will check with our IT Dept. regarding B ("incorrect SQL Server Native Client version is used"), but I have done plenty of other feature editing on this computer without any problem.

 

I also looked at Knowledge Base article 000011778 ("Problem: NIM090672: Specific Microsoft updates may result in data corruption with file geodatabases or shapefiles created on a network share").  Though this specific issue is not applicable (I am running ArcGIS Desktop 10.4.1 on Windows 10 Pro operating system), I wonder if a similar issue with Microsoft Windows Updates could be occurring.  I have been pestered repeatedly in the last few days to restart to finish installing updates, and even though I have scheduled this to occur several times, I keep getting the same prompt. 

I had a very similar problem about 2 weeks ago while editing a different feature class in the same file geodatabase.  Any ideas or suggestions are greatly appreciated!

 

table view of records after records lost

Outcomes