AnsweredAssumed Answered

For what reasons would a service definition leave out features?

Question asked by KatherineMichael on Dec 29, 2017
Latest reply on Jan 19, 2018 by KatherineMichael

While publishing some feature classes from our enterprise geodatabase to ArcGIS Online (AGOL) as hosted feature services, I ran into a strange problem.  One particular feature class will publish to AGOL apparently without error, but the majority of the features will have empty geometry.  I have tried publishing from both ArcMap10.5 and Pro 2.0 with the same result.  

 

It is not the limitation on records returned from the server because this feature class only contains 15 features.  However, the 15 features are multi-part features.  

 

As a workaround, I tried creating a service definition using the geoprocessing tools and then publishing a service from that, but encountered the same result of empty geometry.  

 

Interestingly, if this same feature class is published to our federated ArcServer with the data copied to the server's managed database, the resulting feature service turns up in our Portal completely intact, no empty geometry.  

 

I am curious as to what is causing the empty geometry in the first place, and why the AGOL service ends up with empty geometry but the ArcServer service does not.  Does anyone have any ideas as to a cause? Could the multi-part features be be a problem?

Outcomes