udayaj

Imagery Layer Resampling Issues

Discussion created by udayaj on Dec 20, 2017

Hi all,

I ran into another Imagery Layer raster analysis issue, appreciate if you can provide any help.

I am using ArcGIS Pro's "Resample" raster function to resample an imagery layer (time enabled). I run the resampling using Image Server raster analysis, result is saved as Imagery Layer (hosted).

 

When I use "Bilinear" ResamplingType, it works, but it does not work with "Average" and produces a really bad result like the following one.

 

 

When I use "Majority" as the ResamplingType, it throws the following error.

{"messageCode": "RA_120001", "message": "Distributed Raster Analysis failed. ERROR 999999: Error executing function.\nFailed to open raster dataset\nFailed to execute (GenerateRasterFromRasterFunction).\n."}
Failed to execute (GenerateRaster).
Failed.

 

Further, whenever the resampling works with bilinear, provided output pixel size is auto adjusted (like 1000m into 999.88523...m), there is no way to make this right other than providing the output cell size under "settings" which applies for the environment. But I suspect that it resamples the already resampled data to convert pixel into the right size (from 999.88523...m into 1000m). There is an explanation in the doc for this, but it does not provide any solution.

 

The cell size can be changed, but the extent of the raster dataset will remain the same. Resampling from a user-defined cell size can be much slower than the system default, since the system default resampling processes the minimum amount of data from the closest possible resolution

Resample function—ArcGIS Pro | ArcGIS Desktop 

Outcomes