AnsweredAssumed Answered

WABde 2.6 wont start...

Question asked by erik.lanhammaresri-se-esridist Employee on Nov 12, 2017
Latest reply on Nov 21, 2017 by erik.lanhammaresri-se-esridist

Hello,

 

So Im trying to run wabde 2.6 on my local machine but I get an error message re body-parser deprecated...

Some googling suggested using below...

app.use(bodyParser.urlencoded({  extended: true}));

...before calls to app.use(bodyParser....) in server.js .

 

Tried it but without success. Any ideas how to solve this?

 

Rgds,

/Erik

 

 

Starting node from commando prompt:

 

C:\Archive\ESRI\wabde\wabde26_oktober download\WebAppBuilderForArcGIS\server>node_x64.exe server.js -port=3344
body-parser deprecated bodyParser: use individual json/urlencoded middlewares server.js:206:11
body-parser deprecated undefined extended: provide extended option node_modules\body-parser\index.js:105:29
Server listening tcp connection on port 3344 in development mode
[2017-11-12 11:50:26.670] [INFO] repo - Read repository items: C:\Archive\ESRI\wabde\wabde26_oktober download\WebAppBuilderForArcGIS\client\stemapp\widgets
events.js:141
throw er; // Unhandled 'error' event
^

Error: listen EACCES 0.0.0.0:3344
at Object.exports._errnoException (util.js:873:11)
at exports._exceptionWithHostPort (util.js:896:20)
at Server._listen2 (net.js:1237:19)
at listen (net.js:1286:10)
at Server.listen (net.js:1382:5)
at Object.<anonymous> (C:\Archive\ESRI\wabde\wabde26_oktober download\WebAppBuilderForArcGIS\server\server.js:115:23)
at Module._compile (module.js:409:26)
at Object.Module._extensions..js (module.js:416:10)
at Module.load (module.js:343:32)
at Function.Module._load (module.js:300:12)

Outcomes