AnsweredAssumed Answered

Custom 10.3.1 custom tool parameter changing (adding c$) after 10.5.x edit.

Question asked by rastrauch Champion on Nov 1, 2017
Latest reply on Nov 15, 2017 by rastrauch

This may be one of those things with no answer, but throwing it out there in case someone has seen and resolved.

This is totally something that I caused by an edit of a tool's parameters with 10.5.1 instead of 10.3.1 (too many machines). 

 

I have tools in a toolbox that were written in 10.2.x/10.3.x and have been running fine.  Testing the same tools on (a remote) 10.5.1 machine, and all was running fine, but decided to make some basically (dialog) cosmetic changes.  Typically I would do any Toolbox/Tool GUI changes on my 10.3.1 machine, but I accidentally made some of the parameter changes to a couple of the tools on the 10.5.1 machine, and now those tools will not provide the correct "Default" value (UNC path)...even if I change it. 

 

I usually like to keep "Store relative path names (instead of absolute paths" checked (since I make these into   addins), and this has been working fine. But now the two tools I edited with 10.5.1, when I have a path:   

      \\<server>\<share>\rest\of\path

when I run the program is changes it to

      \\<server>\c$\<share>\rest\of\path

Editing (removing the c$\) looks like it sticks with the apply, but when I run it again, I show it has not changed.  If I unclick the "relative path" box, I can change it and it will stick, but as soon as I check it again, the c$ comes back.

 

I have other tools that did not get edited by 10.5.1 which still work fine (with "relative checked and the exact same path and setup, etc).  I have tried recreating the tool, and tried copying the default path over from one that works.  I have also tried restoring the tool from a back up toolbox (where the tool hadn't been touched by 10.5.1, i.e. from addin in \AssemblyCache folder).  The only thing that seems to work is unchecking the Relative Path box.

BTW - all the .py editing is done externally, without ArcCatalog, so the actual script can be ruled out.

 

Sample 1: with "relative path" unchecked, and fixing the path

 

Sample 2: just checking the "relative path" box

 

This seems like such strange behavior (and might not be worth the effort to pursue), but thought I'd ask if anyone has seen this and knows a solution?     (i.e. anyway to force the "Tool" back to version 10.3.x?)

 

Thanks for you time.

Outcomes