AnsweredAssumed Answered

Disable Snapping for Layers but Allow Layers to be Selected

Question asked by pjordan@drcog.org on Oct 6, 2017
Latest reply on Oct 6, 2017 by pjordan@drcog.org

  So a long time back we were once able to disable snapping for each layer in an .mxd.  Since 10.0 I think it was, that option was no longer available.

 

  I'll simplify this as there are a lot of layers in my .mxd I work with, but generally I have one master line layer that I edit.  Sometimes though I'll have reference layers I get externally that I overlay and at times and I do not want to accidentally snap to those layers if they are displayed when I am editing the master layer, which is what happens.

 

  My work around for this was that I created a new Basemap Layer.  Any layer I didn't want snapped, I would move into that basemap layer and have "snap to Basemap layers" unchecked in the Snapping Options, and this worked great for the past 2 or so years that I used this and the last time I was using this .mxd a few months ago.

 

  Now the issue is, I'm finding an incredible lag when any layer (either turned off or on) is under that basemap layer.  So I don't know what could be different in the past few months that this is now an issue when it never has been in the past and nothing in this .mxd or any of the associated files in it have been touched since?

 

  Any suggestions either to fix this lag issue with the basemap layer?  Or is there any new way to not have layers snappable without using a basemap layer as I did above?

 

  (I have attached what part of my TOC looks like with the basemap layer.  The yellow warning symbols have always been there any time I move something under that basemap layer and never has caused an issue.  Can't recall why those warning symbols always show up, unless it's just notifying the user that those with the symbol are just being reference under the basemap)

 

Thanks

Attachments

Outcomes