AnsweredAssumed Answered

Figuring out a table join failure

Question asked by mschmidtjr on Sep 29, 2017
Latest reply on Sep 29, 2017 by terryiffland

Trying to figure out a Join failure, done in AGO Analysis steps:
In this map (temporarily publically shared): https://arcg.is/0uCSvb
We have tried these joins:
Result               target:"precinct2010"              layer to join:"BC county..." table at bottom
failed                     VTD_1                                                   VTD_1
worked                 NAME                                         NAME+PRECINCT
This resulted is the "BC county precinct data" layer as mapped.

 

But now we have a problem:
Result               target:"precinct2010"                 layer to join:"AA county voters..." table at bottom
failed                    NAME                                            matchv2
failed                     VTD                                              matchv3
These find no matches, even though they both seem to match. We think they are all string/text fields and it's hard for them to be otherwise with letters or embedded dashes in them. In the tables to be joined, we have to use CONCATENATE to construct the join field correctly but have then done copy/paste special to get values only in the field checked for joining (no longer a formula).

 

Anyone have ideas on what this problem could be? Suggestions? We can try the join in ArcGIS desktop, but will still want to use a Join to keep from having to type in lots of numbers. Thanks for any help.

Outcomes